Wednesday, 9 February 2011

No More Support For Android 1.5 (Cupcake) In All Dooblou Applications

From this moment on, all the SECuRET applications, WiFi File Explorer and GroovyCam LiveStream will no longer continue to support Android 1.5 (Cupcake) with new features. The lowest version of Android they support from now on is 1.6 (Donut).

As Android develops at its rapid pace, cool new features are made available to developers with each new version. I have done my best to support older versions of Android for as long as possible, but it got to a stage that features I wanted to implement in my applications could only be possible using Android 1.6 and above. As Android 1.5 is now almost 2 years old and represents less that 4% of the active install base on Android handsets, now seemed as good a time as any to discontinue support for those devices and to concentrate on developing features that can be appreciated by the wider audience.

So what does this mean if you have bought a license for one of my paid applications and you are still using Android 1.5? Well, it means that you must remain on that last version of the application that supported Android 1.5 and you must not update the application, else it will cause an installation error.

I cannot refund you as changing the minimum supported version of Android is allowed in the developers’ terms and conditions, and it is inevitable that all applications will have to do the same in the future (if they haven’t done already). The Market should prevent you from seeing such updates and stop you from updating to a version that isn’t supported, but it is clear from a couple of emails I have already received that the Market has failed to do it's job on a couple of occasions.

If you have problems and cannot roll back to a good version of one of my applications for your version of Android, then please email me and I will send you a link to a direct download.

So goodbye to Cupcake users – sorry to see you go. I’d recommend that if you can, updating to a newer version of Android is a very worthwhile thing to do; you’ll be impressed! And if you do get a new device that supports Android 1.6 or above, you will still have the license for the application you bought from me, so you can re-install that great dooblou application that you loved so much from your old phone at no additional cost ;)